MS Word RCE Vulnerability: 17yrs Old Bug affects All Version of MS Office Package

Skeletons in the closet — MS Word RCE Vulnerability

Almost for 17 years, a critical security bug was present in Microsoft Office package which was even didn’t knew by Microsoft.

Embedi – a security based company specializing in cybersecurity solutions for embedded devices, published their recent research which exploits 17years old Vulnerability exits on Microsoft Office Package.

The vulnerability has been assigned with the CVE ID-2017-11882 and is extremely dangerous and critical.

Why Critical and Dangerous?
As you read above is right because this vulnerability affect every version of MS Office Package.
Here are some Key points-

  • Works with all the Microsoft Office versions released in the past 17 years (including Microsoft Office 365).
  • Works with all the Microsoft Windows versions (including Microsoft Windows 10 Creators Update)
  • Is relevant for all the types of architectures
  • does not interrupt a user’s work with Microsoft Office
  • If a document is opened, the vulnerability does not require any interaction with a user to be exploited.
Now you got how critical it is.  But don’t get panic as Microsoft have already fixed this bug.
Share:
Written by Momodu Arimiyahu
Momodu Arimiyahu is the Founder and Editor-in-chief of 'TechMedNG'. He is a Software/Web Developer, Digital security Expert. He gives tutorial on programmer language and he also run private services for companies. Apart from this he is an Internet activist who loves to learn about technology innovations with so much interested in Cyber Security and Technology. You can connect with him on Facebook | Twitter | LinkedIn | Instagram | YouTube | Whatsapp